FAQ  •  Login

Persistent problem with all old-school games

Moderator: Moderators

<<

Lord of the Wicked

Post Sun Aug 19, 2007 9:25 am

Persistent problem with all old-school games

Unlike many users on this forum, I never managed to run any of the FPS legends on my PC (besides DooM, because it has many mods). I am a great fan of BLOOD, Wolfenstein 3D, Duke 3D, and really want to try out Shadow Warrior. All these games except SW ran on my old WinXP PC, without Sound FX, but with music and a steady framerate.
However, I had to upgrade my computer sooner or later, and so I did. But none these classics ever ran again. They just start loading, then freeze and disappear.
I have tried the tips provided by this site, and by some users (as Blood to Perfection), but none worked. I swear I did everything exactly as said, but the games just wouldn't start.
I also have MS Virtual PC installed, and a virtual drive with MS-DOS 7.xx, and when I tried the games there, blood wouldn't start, Duke needed a cd I didn't have, SW started without any sound and a very slow framerate, and Wolf3d just didn't have any sound.

So I would want to ask anyone that could help to provide some advice, please! These games are unique, and such marvels cannot be found today anymore, and would appreciate any help given...
<<

Guest

Post Wed Oct 07, 2009 2:29 am

Give Dosbox a try, working great for me.
http://dosbox.sourceforge.net


Last bumped by Anonymous on Wed Oct 07, 2009 2:29 am.

Return to BuildXP

Who is online

Users browsing this forum: No registered users and 6 guests

cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.