Black Screen

Discussion about using or improving the BuildXP guide.

Moderator: Moderators

Post Reply

Black Screen

Post by Guest » Thu Apr 05, 2007 2:29 pm

I'm having a problem running Blood on my laptop.
I did everything the BuildXP guide said but when i run the game through the downloaded shortcut, i can hear music and sound but all i see is a Black screen!

How do i fix this?

I have Intel Duel Core 1.7 CPU, 512 DDR Ram, a built-in "Intel 945GM Express" graphics card.

I have disabled many 3D settings in the gfx card options to increase performance and FPS in games like CS but i dont think it would effect Blood.

Please help me solve this problem, Thanks in advance!

P.S: this website rocks!! ;)

Posts: 1
Joined: Sat May 12, 2007 5:33 pm
Location: London, England

Post by Rhort » Sat May 12, 2007 5:54 pm

Hi chaps. I'm having exactly the same problem as this. Whilst I'm open to the possibility that I may have failed to follow the instructions correctly, I've tried this twice now, and it fails in precisely the same manner. :(

Anyone have any suggestions?


Post by Sidious » Wed Oct 07, 2009 2:21 am

1.install blood
2. install vdmsound 2.10
3. install VDMSound LaunchPad Shell Extension v1.0.1.1
4. go here:
download this patch:
r0011.exe - Updates Blood (Registered) from 1.00 to 1.11.(install it)
5. get the soundblaster fix patch: it)
6. get nolfb.exe, place it in the blood folder
7. get cli2nop, run it. (type "cli2nop -p blood.exe")
8. download a VMDSound shortcut for blood here: it doesn't start the download procedure, right click on this link and chose "save link as")
once downloaded, create duplicates of this blood.vlp file and rename them to setup.vlp and commit.vlp. You must of course edit the files created and make them point to their respective .exe files in the blood folder.

9. Blood to perfection:
open up your VMDSound folder, find the VDMS.ini file and open it.
scrolling down the file you will find a section called:
[DMA Transfer Manager.config]
by default the minDMAPeriod is set to "5". change it to "1". save and close.
now you need to download a patch for a windows file:
install it, and chose "y" to reboot.
Sound configuration:
enter Blood's setup by clicking on the setup.VLP file. These are the correct music/sound settings:
Sound FX Card: SoundBlaster
-Address: 220
-Type: Sound Blaster 16 or AWE32
-Interrupt: 7
-8 bit DMA: 1
-16 bit DMA: 5
Music Card: General MIDI
-Midi port: 330

Screen setup:
chose "VESA modes" and 800x600

9.Edit your blood.vlp/commit.vlp file:
right click on the .vlp file, select "properties".
in the "VDMSound" tab, there is a square containing the MIDI emulation.
by default, this is set to "other". change it to "General MIDI (GM) or GS"
now, click on the "advanced" button and find the "Performance" tab.
here you will find a square containing the "DMA servicing". by default the minimum "Polling period" is set to 5. change this to 1. now settings in the .vlp file will be coherent with the settings you did in the VDMS.ini file and you will no longer get the "unhandled exception" error when starting blood from your .vlp files.
game will be smooth, and the sound is perfect

get commit.exe version 1.4
commit.vlp: right click on it, and select the "advanced" button. find the "compability" tab. at the bottom, enable "low level network support".
install nwlink ipx/spx transport protocol
to do this:
start->control panel->network connections
right click on the connection u are using. click on "install". chose the right protocol.
to be able to play a multiplayer game in blood, all players must reside in the same ipx network, and the specific network number for that network has to be "00000000" (8 zeros).
to do this:
double click on the ipx/spx protol you just installed.
set internal network number to "00000000" - 8 zeros.
just to be sure everything is ok, go to start->run. type "cmd", which opens the command prompt. type "ipxroute config".
correct settings shows:
IpxLoopbackAdapter 1234cdef
theNameOfYourConnection 00000000
allTheOtherConnections 00000000

last of the last things:
to play multiplayer, you can only have ONE connection activated in "network connections", which is the connection containing the network card that's been given the ip-address from your dhcp-server. If you have more than 1 network card installed on your system, you need to deactivate that connection, or else upon launching commit, blood will search the network and find that network adapter and say: "found 2 players". blood thinks that it's a player, which it of course isn't.

Last bumped by Anonymous on Wed Oct 07, 2009 2:21 am.

Post Reply