Blood won't even start in xp

Discussion about using or improving the BuildXP guide.

Moderator: Moderators



Post by Guest » Tue May 15, 2007 9:17 pm

normal Graphic mod? What do you mean by that?


Post by Guest » Tue May 15, 2007 9:40 pm

320x200 maybe?

I'm getting the PhysicaltoLinear error too. One thing I notice is that every time I quit the setup (and save) after changing to 640x480 is that it resets back to 320x200. It's really frustrating, and might be the problem. What can I do about it?


Post by Sidious » Tue May 15, 2007 11:57 pm

The PhysicaltoLinear error can be fixed this way:
1. Get and put it inside your blood folder.
2. right click on your blood.vlp file, chose "advanced". then find the
DOS environment tab. click to activate "additional options", then type in:
where the GAMES folder is the location of your Blood game.


Post by Guest » Wed May 16, 2007 8:57 pm

Ok, cool...but that brings me to a different problem, which is why I had been trying to open the Blood executable with VDMS instead of using the blood.vlp file. Whenever I try to open that file, my computer asks me to specify a program to open it shouldn't need another program to open it, should it?


Post by Sidious » Wed May 16, 2007 11:58 pm

Looks like u havent installed the VDMS launchpad correctly. you should reinstall VDMS and the launchpad, then try again. but first try this:
1. create a new file called blood.bat
2. edit the file and type this is:
@echo off
c: *
cd\ *
cd games *
cd blood *

*on my computer blood resides in a "games" folder on my C drive. you would of course have to write the correct path in the blood.bat file.


Post by Sidious » Thu May 17, 2007 3:05 am

Btw, you really should get off VMDSound, its no good. Both for single player and network play, its....bad! use Dosbox, but not the 0.65. you need a specific CVS build:
Go here: ... e8199ceb15
on that page, click on this link:
download DosBox
after that, you can download an application named Dukonnector.
its a program that allows hosting and joining of old dos based games. it takes advantage of the dosbox' source and makes it easier to host and join network games. its a GUI for network play using dosbox. very nice application.
get Dukonnector here:



Post by Guest » Thu Jul 05, 2007 10:25 am

Is there a step by step guide how to play Blood in Multiplayer by using dukeconnector anywhere?
I'm absolutely not used to DOSBox and this application.


Different error text

Post by Daxter221 » Thu Oct 25, 2007 2:15 am

Could anyone help me out with this error? It happens in the same general way in all of the errors in this thread... the screen loads blood, then the cmd prompt flashes for a split second with an error..

Playback failed, possibly due to an invalid or conflicting IRQ.

Any help would be awesome : )

Posts: 2
Joined: Thu Jan 10, 2008 9:09 pm

Post by chico008 » Mon Jan 14, 2008 5:22 pm

Hi, have som problems while trying to run blood on XP with vdms.
when i start it, i get the loading states, and then black screen, and come back to windows.
In VDMS error log i have this message :
@E - SB Controller
Attempted to read from an unknown mixer register (register = 0x83)
@E - SB Controller
Attempted to write to an unknown mixer register (register = 0x83,
value = 0x0b)

SB is properly configured, and have the same parameters in VDM and in blood config file.

If someone can help with this error, I thanks him.

Posts: 11
Joined: Fri Feb 15, 2008 1:00 pm

Post by White.Sux » Fri Feb 15, 2008 4:39 pm

its weird but i got it to run yesterday............

the first time i was using deathmasks instructions it worked without any problems for me 3 years ago

now i have a new pc and tried the whole thing again ! and it didnt worked but i got it to work...........all i get is a error message but thats not bad i just click ok and the game loads up......and is working fine........well the only thing i complain about is the sound it sucks a little bit but its okay as time goes by

and I had the SAME ERRORS like some people here LIKE THE ERROR with the DEMO HEADER or DPMI LINEAR ERROR......

if this thread is still active i will write down how i got it to run.......not
that i write the stuff down here and nobody will take a look at it......


Post by Axim » Wed Apr 16, 2008 9:13 pm

After doing EVERYTHING in the HowTo, this is what happens when I try to start Blood:

What can I do? Please help me.

Posts: 1
Joined: Sun Apr 20, 2008 7:47 pm

Post by nanobiot » Sun Apr 20, 2008 7:50 pm

Thanks for best how2.
fixed Axim problem.
game started, but have new error:

VDMS Launchpad - blood
NTVDM CPU has detected an invalid instruction.
[Close] [Skip]


Post by Guest » Sat May 24, 2008 12:51 am

same problem as axim
pls help :(


Post by DEiwos » Sat Aug 16, 2008 11:11 am

I had the same error Axim encountered. Solved it by checking the VDM directory in the desktop shortcut; I had VDMS installed in a different directory and edited the path. Sadly, that only lead me to encounter the "#11 header ..." error which I didn't solve yet :/.


Post by Guest » Tue Feb 10, 2009 1:05 pm

got the same problems like


i got the blood version 1.21 is that maybe the problem?

Post Reply